UNLV power outage
Incident Report for UNLV
Resolved
Power has been fully restored in the buildings affected by this evening's outage.

Service Status:
Campus Services - Operational
Posted 2 months ago. May 01, 2018 - 20:20 PDT
Identified
Multiple building on campus are currently experiencing a power outage.

Service Status:
Applications - Partial Outage
Posted 2 months ago. May 01, 2018 - 16:56 PDT