Turnitin Maintenance
Incident Report for UNLV
Resolved
Turnitin maintenance is complete and WebCampus is running as expected.
Posted 28 days ago. Sep 22, 2018 - 15:41 PDT
Identified
Turnitin will be performing proactive emergency maintenance on Saturday, September 22 from 8:00am to 4:30pm PDT. More details and status updates regarding this maintenance can be found here: https://turnitin.status.io/. Users will be unable to access Turnitin assignments during this time so please plan accordingly.
Posted 28 days ago. Sep 21, 2018 - 16:39 PDT
This incident affected: WebCampus.