Google Drive not performing as expected
Incident Report for UNLV
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 11:16 PST
Update
Users may experience slow load times with the following Google Services,

Google Drive, https://drive.google.com
Google Docs, https://docs.google.com
Google Sheets, https://docs.google.com/spreadsheets
Google Slides, https://docs.google.com/presentation

For more information regarding Google services, please refer to http://www.google.com/appsstatus.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted Jan 27, 2020 - 10:42 PST
Identified
Google Drive is not performing as expected. Users may experience slow load times.

For more information regarding Google services, please refer to http://www.google.com/appsstatus.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted Jan 27, 2020 - 10:24 PST