WebCampus (Blackboard) not performing as expected
Incident Report for UNLV
Resolved
Resolved
WebCampus (Blackboard) course copies feature is performing as expected.

Service Status:
WebCampus - Operational
Posted 10 days ago. May 13, 2018 - 15:33 PDT
Identified
Identified
WebCampus (Blackboard) course copies feature is not performing as expected.

Service Status:
WebCampus - Partial Outage
Posted 10 days ago. May 13, 2018 - 14:26 PDT
This incident affected: WebCampus.