Supplier Registration not performing as expected
Incident Report for UNLV
Resolved
Supplier Registration, https://suppliers.nevada.edu/, is now performing as expected.

Service Status:
Applications - Operational
Posted 28 days ago. Dec 20, 2018 - 15:29 PST
Identified
Supplier Registration, https://suppliers.nevada.edu/, is not performing as expected.

Service Status:
Applications - Partial Outage
Posted 28 days ago. Dec 20, 2018 - 14:01 PST
This incident affected: Applications.