UNLV Office365 self registration not performing as expected
Incident Report for UNLV
Resolved
UNLV Office365 new user self registration is performing as expected.

Service Status:
Applications - Operational
Posted 3 days ago. Oct 17, 2018 - 14:32 PDT
Identified
UNLV Office365 new user self registration is not performing as expected. This does not impact current users accessing Office365 service. Administrators are working with Microsoft to resolve the issue. New users can contact the IT Help Desk to have their account created.

IT Help Desk
ithelp@unlv.edu
702-895-0777

Service Status:
Applications - Partial Outage
Posted 10 days ago. Oct 10, 2018 - 12:07 PDT
This incident affected: Applications.