UNLVMail and Rebelmail not performing as expected
Incident Report for UNLV
Resolved
Since 2:56 p.m. UNLVMail and Rebelmail have been performing as expected.
Posted 2 months ago. Mar 16, 2018 - 14:57 PDT
Identified
In some cases UNLVMail and Rebelmail are displaying most recent email however messages are inaccessible.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted 2 months ago. Mar 16, 2018 - 11:27 PDT
This incident affected: Google Apps (UNLVMail/Rebelmail).