Multiple building experiencing power outage
Incident Report for UNLV
Resolved
Power has been restored to campus.

Service Status:
Network – Operational
Posted 2 months ago. Oct 08, 2018 - 08:15 PDT
Identified
Multiple building on campus are currently experiencing a power outage.

Service Status:
Network - Partial Outage
Posted 2 months ago. Oct 07, 2018 - 10:29 PDT
This incident affected: Network.