Thomas T. Beam Engineering Complex (TBE) power outage
Incident Report for UNLV
Resolved
This incident has been resolved.
Posted Jan 21, 2020 - 13:22 PST
Identified
High Bay Lab (HBL) is also affected by this power outage.
Posted Jan 21, 2020 - 13:08 PST
Investigating
Thomas T. Beam Engineering Complex (TBE) A and B buildings on campus are currently experiencing a power outage. The network is unavailable.

Service Status:
Network - Partial Outage
Posted Jan 21, 2020 - 13:00 PST