MyUNLV self service password resets unavailable
Incident Report for UNLV
Resolved
MyUNLV self service password resets are now working as expected.

Service Status:
MyUNLV - Operational
Posted 5 months ago. May 19, 2018 - 19:16 PDT
Identified
MyUNLV self service password resets are not working as expected. MyUNLV users can contact the IT Help Desk to have their password reset manually, http://bit.ly/unlvithelp, 702-895-0777.

Service Status:
MyUNLV - Partial Outage
Posted 5 months ago. May 19, 2018 - 16:26 PDT
This incident affected: MyUNLV.