Office of Information Technology (OIT) Help Desk phone support unavailable
Incident Report for UNLV
Resolved
Office of Information Technology (OIT) Help Desk phone support (702-895-0777) is available.

Service Status:
Applications - Operational
Posted 5 months ago. Jul 14, 2018 - 08:08 PDT
Investigating
Office of Information Technology (OIT) Help Desk phone support (702-895-0777) is unavailable; visit https://www.it.unlv.edu/it-help-desk for other ways to contact the Help Desk.

Service Status:
Applications - Partial Outage
Posted 5 months ago. Jul 14, 2018 - 07:35 PDT
This incident affected: Applications.