Google UNLVMail and Rebelmail not performing as expected
Incident Report for UNLV
Resolved
Google UNLVMail and Rebelmail have been performing as expected.
Posted Aug 19, 2019 - 14:45 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 19, 2019 - 12:37 PDT
Identified
Google UNLVMail and Rebelmail is not performing as expected.

This service is maintained by a group outside of the Office of Information Technology (OIT).

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted Aug 19, 2019 - 12:32 PDT