Turnitin not working as expected
Incident Report for UNLV
Resolved
Turnitin in Canvas - WebCampus, https://webcampus.unlv.edu/, is performing as expected.

Service Status:
WebCampus - Operational
Posted about 1 month ago. Sep 17, 2018 - 12:19 PDT
Identified
Turnitin in Canvas - WebCampus, https://webcampus.unlv.edu/, is not working as expected.

Service Status:
WebCampus - Partial Outage
Posted about 1 month ago. Sep 17, 2018 - 08:41 PDT
This incident affected: WebCampus.