Tuition Estimator unavailable
Incident Report for UNLV
Resolved
This incident has been resolved.
Posted 23 days ago. May 03, 2019 - 10:56 PDT
Update
Tuition Estimator, tuitioin.cashering.unlv.edu, is now available.

Websites:
Service Status - Operational
Posted 24 days ago. May 02, 2019 - 19:07 PDT
Investigating
Tuition Estimator, tuitioin.cashering.unlv.edu, is currently unavailable.

Websites:
Service Status - Partial Outage
Posted 24 days ago. May 02, 2019 - 18:42 PDT
This incident affected: Websites.