Building Google Groups
Incident Report for UNLV
Resolved
Building Google Groups' membership management is now working as expected.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Operational
Posted about 1 month ago. Dec 14, 2017 - 10:48 PST
Identified
Building Google Groups' membership management is currently not working as expected.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted about 1 month ago. Dec 04, 2017 - 11:48 PST
This incident affected: Google Apps (UNLVMail/Rebelmail).