MyUNLV Payments
Incident Report for UNLV
Resolved
Submitting payments on MyUNLV, https://my.unlv.nevada.edu, is now available.

Service Status:
MyUNLV - Operational
Posted 6 months ago. Jun 09, 2017 - 14:51 PDT
Identified
Submitting payments on MyUNLV, https://my.unlv.nevada.edu, is currently unavailable. Users may receive an error when attempting to make a payment.

Service Status:
MyUNLV - Partial Outage
Posted 6 months ago. Jun 09, 2017 - 14:09 PDT
This incident affected: MyUNLV.