Google UNLVMail and Rebelmail not performing as expected
Incident Report for UNLV
Resolved
Since 4:30 p.m. Monday, May 5, 2019, Google UNLVMail and Rebelmail have been performing as expected.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Operational
Posted 3 months ago. May 07, 2019 - 08:21 PDT
Identified
Google UNLVMail and Rebelmail are not performing as expected. Some users may be receiving error messages when trying to send emails. For more information regarding Google services, please refer to http://www.google.com/appsstatus

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted 4 months ago. May 06, 2019 - 15:20 PDT
This incident affected: Google Apps (UNLVMail/Rebelmail).