Google Drive UNLVMail and Rebelmail not performing as expected
Incident Report for UNLV
Resolved
Google Drive UNLVMail and Rebelmail are now performing as expected.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Operational
Posted 2 months ago. Mar 13, 2019 - 07:48 PDT
Identified
Google Drive, UNLVMail and Rebelmail are not performing as expected. For more information regarding Google services, please refer to http://www.google.com/appsstatus

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted 2 months ago. Mar 12, 2019 - 22:00 PDT
This incident affected: Google Apps (UNLVMail/Rebelmail).