Some students unable to submit work through WebCampus TurnItIn
Incident Report for UNLV
Resolved
Submitting work through WebCampus TurnItIn feature is now performing as expected.

Service Status:
WebCampus - Operational
Posted Nov 06, 2017 - 11:19 PST
Identified
Some students have reported encountering errors when trying to submit work through WebCampus TurnItIn feature.

Service Status:
WebCampus - Partial Outage
Posted Oct 26, 2017 - 22:35 PDT
This incident affected: Applications, Computing Services, MyUNLV, WebCampus, and Websites.