Google UNLVMail and Rebelmail not performing as expected.
Incident Report for UNLV
Resolved
Google UNLVMail and Rebelmail are now performing as expected.

Service Status:
Google Apps (UNLVMail/Rebelmail) - Operational
Posted about 1 month ago. Apr 18, 2019 - 09:28 PDT
Identified
Google UNLVMail and Rebelmail are not performing as expected. Some users may be unable to log in to Rebelmail and UNLVMail. For more information regarding Google services, please refer to http://www.google.com/appsstatus

Service Status:
Google Apps (UNLVMail/Rebelmail) - Partial Outage
Posted about 1 month ago. Apr 17, 2019 - 15:56 PDT
This incident affected: Applications.