Google Workspace Services not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 09:22 PDT

Identified

Various Google Workspace services are not performing as expected. Users may experience latency or see an error message when accessing Gmail, Drive, or Meet. This affects UNLVMail, Rebelmail, and Rebel Alumni Mail domains.

--

UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi_google_workspace
Posted Jul 18, 2025 - 09:00 PDT
This incident affected: G Suite (Gmail (UNLVMail/Rebelmail), Google Drive, Google Meet).