UNLV TeamDynamix Ticketing System Experiencing Performance Issues

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 15:05 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2025 - 13:42 PST

Identified

The UNLV TDX ticketing system is currently experiencing performance issues and may not be functioning as expected. Work requests, inquiries, and emails submitted to UNLV IT or Business Affairs utilizing the TeamDynamix (TDX) platform may be delayed, inaccessible, or unable to process properly during this incident.

The UNLV IT Help Desk remains open and available to assist. Work requests can still be submitted by phone at 702-895-0777, or in person at the following locations:
- Student Union (SU) 231
- Carol Harter Classroom Building (CHB) B113

We appreciate your patience as our teams work to restore full functionality to TDX.

--

UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi-tdx
Posted Nov 10, 2025 - 07:17 PST
This incident affected: Applications.