Docusign not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 15:31 PDT

Identified

Docusign eSignature is not performing as expected due to an outage from the Docusign service provider. Users may be unable to prepare, review, or sign documents when using Docusign.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi-docusign
Posted Jul 30, 2026 - 13:34 PDT
This incident affected: Applications.