Atrium Online Deposits for Guests not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 08:41 PST

Identified

Atrium Online Deposits, https://rcs.it.unlv.edu/paymentcc.php, is not performing as expected. Users may be unable to submit online deposits using 'Deposit RebelCash' option.

Deposits are still available for users with a valid ACE account via the 'Student & Staff' login option as a workaround.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi-atrium-deposits
Posted Feb 12, 2026 - 08:05 PST
This incident affected: Websites.