Workday UI Elements not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 08:37 PDT

Identified

Certain UI elements within the Workday site are not performing as expected. Users may experience delays when interacting with inbox items listed under "My Tasks", in addition to other various UI tasks from different product areas, such as suppliers, supplier invoices, and job requisitions. Workday is investigating and actively working to find a resolution as soon as possible.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777
Posted Jul 31, 2025 - 12:06 PDT
This incident affected: Workday (Workday).