MyPhoto unavailable

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Aug 08, 2026 - 10:34 PDT

Identified

MyPhoto, , is currently unavailable.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777
Posted Aug 07, 2026 - 11:27 PDT
This incident affected: RebelCard (Online Photo Submission).