Dolphin Software not performing as expected
Incident Report for UNLV
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 12:36 PDT
Identified
School of Dental Medicine Dolphin Software is not performing as expected. Some users are experiencing slowness when using the Dolphin application.

--
Office of Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi_dolphin_software
Posted Apr 18, 2024 - 09:49 PDT
This incident affected: Applications.