Microsoft not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 08:47 PDT

Identified

Microsoft 365 and Microsoft Azure are not performing as expected. Users may experience issues with delays when accessing other Microsoft services. We will be following the updates provided by Microsoft at https://status.cloud.microsoft/ for more information.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777
Posted Oct 29, 2025 - 10:57 PDT
This incident affected: Applications and Computing Services.