Services have been restored to the Student Union (SU) building and we are continuing to monitor this incident.
Posted Jul 15, 2025 - 07:56 PDT
Identified
The SU IT Help Desk & SU 233 Computer Lab has been closed at 4:40 PM on July 14 due to a cooler system malfunction resulting in a building closure. Services are expected to resume on Tuesday, July 15, per normal business hours with the IT Help Desk available 8am - 5pm at both locations SU 231 or CHB B 113 for support. If the SU location remains unavailable beyond July 15, a follow-up communication will be sent to campus with further updates.
The IT Help Desk will continue to provide walk-in support at the CHB-B location. Other Computer Lab locations are unaffected and the TBE-A311 Computer Lab will remain open until 9 PM.
Thank you for your understanding.
-- UNLV Information Technology IT Help Desk ithelp@unlv.edu 702-895-0777
#mi_su-closure
Posted Jul 14, 2025 - 17:10 PDT
This incident affected: Computer Labs (Computer Labs), IT Help Desk (IT Help Desk - Student Union (SU)), and Campus Network (SU).