UNLV IT Services Update
Incident Report for UNLV
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 09:52 PST
Update
Technology Support Update, Jan. 2, 2024

The RebelCard and IT Help Desk offices are now open at their normal in person locations in the Student Union and Classroom Building Complex, Carol C. Harter.
Posted Jan 02, 2024 - 16:38 PST
Update
Technology Support Update, Dec. 22, 2023

RebelCard location at Lied Library will close at noon today. Customers will be directed to the IT Help Desk for assistance.
Posted Dec 22, 2023 - 12:02 PST
Update
Technology Support Update, Dec. 18, 2023

The IT Help Desk and RebelCard are offering in-person support in the Lied Library from 8 a.m. to 5 p.m. Dec. 18 to Dec. 22. Visit the UNLV IT site for updated IT services and hours for in-person and remote support. Please continue to check unlvstrong.unlv.edu for further campus updates.
Posted Dec 18, 2023 - 09:52 PST
Update
Technology Support Update, Dec. 11, 2023

The IT Help Desk and RebelCard are offering in-person support in the Lied Library starting Dec. 11. Device loans can be dropped off at this location. Select computer labs will be open. Visit the UNLV IT site (https://www.it.unlv.edu/support-service-hours) for updated IT services and hours for in-person and remote support. Please continue to check unlvstrong.unlv.edu for further campus updates.
Posted Dec 11, 2023 - 12:38 PST
Update
IT Help Desk Phones now available

Intermittent issues with IT Help Desk telephone lines have been resolved and support is now available at 702-895-0777. Ongoing work continues to resolve further network issues.
Posted Dec 07, 2023 - 17:29 PST
Update
IT Help Desk Phones Unavailable, Use Chat and Email For Support

Due to ongoing network issues, IT Help Desk telephone line support is intermittently unavailable. Please use our chat, email, or support portal for help as administrators work to resolve this issue as soon as possible.
Posted Dec 07, 2023 - 15:55 PST
Identified
All on-campus UNLV IT services, including IT Help Desk, computer labs, and RebelCard, are closed though December 10 due to the campus closure. Remote service options remain available, including:

* UNLV IT Help Desk support is available from 8 a.m. - 8 p.m. daily. For multifactor authentication assistance and other urgent needs, please call the IT Help Desk at 702-895-0777. Otherwise, we encourage you to use chat, web support portal, or email for assistance. Please see available support options at it.unlv.edu/help.
* Virtual computer lab access is available 24/7 though RebelApps at it.unlv.edu/rebelapps.
* Manage your RebelCash balance online at unlv.edu/rebelcard.

If you need assistance with accessing spaces on campus, please contact Rebel Repair (unlv.edu/rebelrepair) for all dorms and Student Life facilities and University Police (unlv.edu/police) for all other spaces.

We appreciate your patience and understanding as we work to support the campus during a difficult time for our community.

For campus-wide announcements, see unlvstrong.unlv.edu.
Posted Dec 07, 2023 - 11:16 PST
This incident affected: RebelCard (Card Printing), Computer Labs (Computer Labs), and IT Help Desk (IT Help Desk - Student Union (SU), IT Help Desk - Classroom Building Complex (CHB)).