UNLV eFax not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 13:06 PDT

Identified

UNLV eFax, https://fax.voice.unlv.edu/login, is not performing as expected. Users may experience issues when attempting to use the UNLV eFax service.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777
Posted Jun 30, 2025 - 12:20 PDT
This incident affected: Computing Services.