RebelCard Services not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 08:51 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2025 - 10:34 PDT

Identified

RebelCard services are not performing as expected. New RebelCards are currently unable to be issued and RebelCash transactions are unavailable. Users may experience issues with any payments and services that are executed through RebelCard/RebelCash.


--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi_rebelcard-atrium
Posted Aug 14, 2025 - 10:06 PDT
This incident affected: RebelCard (Card Printing, Transact, Quad Point Point of Sale, RebelCard).