Flora Dungan Humanities (FDH) power outage

Incident Report for UNLV

Identified

Power and wired connections within the Flora Dungan Humanities (FDH) building have been restored, however FDH is continuing to experience wireless connectivity issues.

Users may still experience issues connecting to the wireless network in and around the FDH building.
Posted Jul 14, 2025 - 16:05 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 13:08 PDT

Update

Work is ongoing to resolve the power-outage in FDH.

Outage was caused by a water leak from the 8th floor water heater which is also affecting the FDH Fire Protection systems and plumbing as well. New water heaters are expected to be installed today which should resolve these issues. Fire risk is being monitored and the FDH building is otherwise safe to work in.
Posted Jul 14, 2025 - 08:54 PDT

Identified

Flora Dungan Humanities (FDH) building is experiencing a power-related outage. Users may experience issues with the facility power and the UNLV wired/wireless networks.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi_fdh-outage
Posted Jul 13, 2025 - 06:49 PDT
This incident affects: Campus Network (FDH).