Flora Dungan Humanities Building (FDH) fifth floor network outage

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 08:03 PDT

Identified

The fifth floor of the Flora Dungan Humanities (FDH) building is experiencing a network outage.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi-fdh-network
Posted Jul 17, 2026 - 07:18 PDT
This incident affected: Campus Network (FDH).