Lucid Suite Premium is not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Dec 31, 2025 - 12:40 PST

Monitoring

A fix has been implemented - most Premium Lucid Suite users have had their license restored and we are working to fix the remaining licenses.
Posted Dec 31, 2025 - 11:21 PST

Identified

Lucid Suite Premium is not performing as expected. Premium users of Lucid Suite have been downgraded to Free licenses. Edits will now be limited to the 3 most recently created Lucidchart documents and the rest will be view only.

Users with a free license, such as students and professors that have signed up for Lucid through Canvas, should not be affected.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi-lucid-suite
Posted Dec 31, 2025 - 08:24 PST
This incident affected: Applications.