Slack features not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted May 14, 2026 - 08:43 PDT

Identified

Certain features of the UNLV Slack environment, https://unlv.enterprise.slack.com, are not performing as expected. Users may experience errors when attempting to upload files & attachments, edit messages and channels, and run some workflows.

Slack is aware of the outage and is working to restore feature functionality.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777
Posted May 14, 2026 - 08:16 PDT
This incident affected: UNLV Slack (Slack Messaging, Slack Apps/Integrations, Slack Apps/Integrations/APIs, Slack Posts/Files).