Rebelcard not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 14:14 PDT

Identified

Rebelcard's (RebelCash & Dining Dollars) flex spending account balances are overstated. RebelCash balance is also showing up as Dining Dollars balance even if you don't have Dining Dollars


--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777
Posted Jun 06, 2026 - 10:52 PDT
This incident affected: RebelCard (RebelCard).